• 이윰빌더 시즌 4
  • 테마/스킨상점
이윰

공유자료실

[시즌4] CKEditor (ckeditor4_eyoom_1.0) - 웹에디터

배포파일 : plugin.zip (775.7K)
다운로드횟수 : 73|최종수정일 : 2019-05-02 11:46:37

본문

안녕하세요.

현재 이윰넷에서 사용중인 CKEditor 이윰빌더 버전인 ckeditor4_eyoom - 웹에디터 를 설치하실수 있게 공유자료실에 해당 파일을 업로드 합니다.

(시즌3 공유자료실의 CKEditor와 동일합니다.)

 

 

참고로 코드 하이라이트 기능도 추가 해 놓았습니다.
아래 아이콘 모양 클릭하면 코드 스니펫 창이 뜨고 거기에서 프로그램 언어 설정한 후 코드를 삽입하면 됩니다.

 

설치방법 및 적용방법

  1. 해당 파일을 다운로드 받으시고 압축을 풀어주시기 바랍니다. (plugin 폴더가 생성됩니다.)
  2. 그누보드5 또는 영카트5 설치하신 곳에 해당 폴더를 업로드 합니다. (plugin 폴더에 덮어 씌우시거나 안의 내용을 업로드 하시면 됩니다.)
  3. 관리자 - 환경설정 - 에디터설정 에서 ckeditor4_eyoom을 선택하시면 관리자페이지의 에디터 또는 게시판 에디터로 사용가능합니다.

 

감사합니다.

3
로그인 후 추천 또는 비추천하실 수 있습니다.
추천한 회원 보기

댓글목록 12

나남씨님의 댓글

감사합니다~!이모티콘

축하합니다. 첫댓글 포인트 36포인트를 획득하였습니다.

KingCrab님의 댓글

감사합니다 잘 쓰겠습니다!ㅠㅠ

나남씨님의 댓글

GIF나 동영상은 드래그 복사가 안되네용..

KingCrab님의 댓글

감사합니다! 잘쓰겠습니다 :)

라떼님의 댓글

닭발은세개님의 댓글

회원사진

고맙습니다. ^^
4.11.1 버전이 최신이던데  혹시 최신버전을 반영하려면 어디를 수정해야 할까요?

relainworld님의 댓글

감사합니다. 어떻게 쓰는지는 이제 알아봐야겠네용

빨강모자님의 댓글

회원사진

잘 활용할꼐요....감사합니다.

님투님의 댓글

이 에디트 플러그인을 덮어 씌운 후에
일부 기능 ( 게시판 수정 및 에디터 사용하는 곳에 에러가 발생하고 있습니다.)

editor.lib.php  파일도 업데이트 되어야 하는게 아닌가요 ?  게시판 설정에서 이부분이 에러가 나서

editor_html() / get_editor_js()  사용된 부분에서 에러가 나네요

이미지를 보면


<link rel="stylesheet" href="http://rootfarm.co.kr/adm/eyoom_admin/theme/basic/plugins/bootstrap/css/bootstrap.min.css" type="text/css" media="screen">
<link rel="stylesheet" href="http://rootfarm.co.kr/adm/eyoom_admin/theme/basic/plugins/fontawesome5/css/fontawesome-all.min.css" type="text/css" media="screen">
<link rel="stylesheet" href="http://rootfarm.co.kr/adm/eyoom_admin/theme/basic/plugins/eyoom-form/css/eyoom-form.min.css" type="text/css" media="screen">
<link rel="stylesheet" href="http://rootfarm.co.kr/adm/eyoom_admin/theme/basic/plugins/perfect-scrollbar/perfect-scrollbar.min.css" type="text/css" media="screen">
<link rel="stylesheet" href="http://rootfarm.co.kr/adm/eyoom_admin/theme/basic/plugins/waves/waves.min.css" type="text/css" media="screen">
<link rel="stylesheet" href="http://rootfarm.co.kr/adm/eyoom_admin/theme/basic/css/common.css" type="text/css" media="screen">
<link rel="stylesheet" href="http://rootfarm.co.kr/adm/eyoom_admin/theme/basic/css/style.css" type="text/css" media="screen">
<link rel="stylesheet" href="http://rootfarm.co.kr/adm/eyoom_admin/theme/basic/css/custom.css" type="text/css" media="screen">


이 부분이 사라져서 제대로 표현이 안됩니다.



function editor_html($id, $content)
{
    return "<textarea id=\"$id\" name=\"$id\" style=\"width:100%;\" maxlength=\"65536\">$content</textarea>";
}


// textarea 로 값을 넘긴다. javascript 반드시 필요
function get_editor_js($id)
{
    return "var {$id}_editor = document.getElementById('{$id}');\n";
}


//  textarea 의 값이 비어 있는지 검사
function chk_editor_js($id)
{
    return "if (!{$id}_editor.value) { alert(\"내용을 입력해 주십시오.\"); {$id}_editor.focus(); return false; }\n";
}

이윰MOUNT님의 댓글의 댓글

회원사진

안녕하세요.

우선 불편을 드려 죄송하며, 버그&건의 게시판에 남겨주신 글에 답변을 드렸는데, 혹시 여기도 동일하게 내용을 남깁니다.

ckeditor_eyoom_1.0 폴더명의 버전 소수점 때문에 에러가 나는것 같습니다.
그누보드가 패치 되면서 해당 부분에 대한 수정이 있었던듯 합니다.

업로드한 아래의 폴더명을
/plugin/editor/ckeditor4_eyoom_1.0 의 폴더명을
/plugin/editor/ckeditor4_eyoom 으로 수정하신 후

관리자페이지 - 환경설정 - 기본환경설정의 '에디터 선택'을 ckeditor4_eyoom 설정하여 저장하시면 정상적용 되실거에요.
해당 부분은 본 글에 새로 파일 업로드 하였습니다.

감사합니다.

홀민님의 댓글

너무 이쁘네요.
헌데 약간 흠이 있다면
필요없는 메뉴도 너무 많네요.ㅠㅠ

간단하기는 스마트에디터2가 심플해서 좋은데 이쁘기는 ckeditor4_eyoom가 이쁘고..
또 sir에 갔더니.trumbowyg라는 에디터도 심플하네요.

trumbowyg 를 이윰버젼으로 제작하실 의도는 없으신지?
https://sir.kr/g5_plugin/4984

아니면 ckeditor4_eyoom lite 버젼 제작 의향은 없으신지?

어려운부탁 드려 죄송합니다.

김유성님의 댓글

감사합니다.
잘 적용해보겠습니다.

전체 9 건 - 1 페이지
제목
회원사진 이윰MOUNT 1,319 3 2018.08.14
회원사진 이윰MOUNT 954 1 2018.09.18
회원사진 이윰MOUNT 989 1 2018.09.18
회원사진 이윰MOUNT 572 2 2018.09.18
회원사진 이윰MOUNT 604 1 2018.09.18
회원사진 이윰MOUNT 876 2 2018.08.28
회원사진 이윰MOUNT 601 3 2018.08.27
회원사진 이윰MOUNT 1,030 1 2018.08.24
회원사진 이윰MOUNT 1,100 4 2018.08.20