• 이윰빌더 시즌 3
  • 테마/스킨상점
이윰

이윰빌더 시즌3

이윰빌더 3.0.7 with [보안패치] 영카트 5.3.1.8

  • - 첨부파일 : EB_3.0.7_patch.tar.gz EB-3.0.7 패치파일 (18.6K) - 다운로드

본문

이윰빌더 시즌3 - EB_3.0.7 버전입니다.

 

이번 버전은 영카트 5.3.1.8 버전을 적용한 버전입니다.
풀패키지가 아닌 이윰빌더만 또는 패치파일로만 업그레이드할 경우, 반드시 그누보드 5.3.1.8(또는 영카트 5.3.1.8) 버전으로 패치해 주셔야 합니다. 

 

-- 작업내역 : 시작 --

01. 이윰빌더 시즌3 버전을 3.0.7 버전으로 변경
M : eyoom/common.php


02. 쇼핑몰 상품관리 분류리스트 조건 검색 후 페이징 링크에서 검색이 풀리는 버그 패치 - 히스토리님이 제보해 주셨습니다.
M : admin/core/shop/itemlist.php


03. 관리자모드 상품검색 후, 페이징 버그 패치
M : admin/core/shop/itemlist.php


04. 시즌3 테마를 그누 콘텐츠몰에서 구매할 경우, 설치가능하도록 기능 개선
M : admin/admin_theme/admin_basic/skin_bs/theme/basic/theme_form.skin.html
M : admin/admin_theme/admin_basic/skin_bs/theme/basic/theme_manager.skin.html
M : admin/core/theme/theme_form.php
M : admin/core/theme/theme_form_update.php


05. 영카트 5.3.1.8 버전 관련 파일 패치
M : admin/core/board/faqlist.php
M : admin/core/member/member_list_update.php
M : admin/core/shopetc/itemeventformupdate.php


06. 테마 설정 변경에서 불필요한 소스 테마키 체크 로직 제거
M : admin/admin_theme/admin_basic/skin_bs/theme/basic/config_form.skin.html

-- 수정내역 : 끝 --


감사합니다. 

댓글목록 2

디폴트님의 댓글

감사합니다

축하합니다. 첫댓글 포인트 44포인트를 획득하였습니다.

이윰넷님의 댓글

회원사진
이번 그누보드5 및 영카트5 보안패치에는 /adm/admin.lib.php 파일이 수정되었습니다.

별도로 그누보드5 및 영카트5를 업그레이드하실 경우, 다음 작업을 해 주셔야 합니다.

--- 다음 ---
1. /adm/admin.lib.php 파일 416번째 라인 소스 수정
[수정전]
    if( $p['path'] && ! preg_match( '/\/'.preg_quote(G5_ADMIN_DIR).'\//i', $p['path'] ) ){
        $msg = '올바른 방법으로 이용해 주십시오';
    }


[수정후]
    if( $p['path'] && ! preg_match( '/\/('.preg_quote(G5_ADMIN_DIR).'|admin)\//i', $p['path'] ) ){
        $msg = '올바른 방법으로 이용해 주십시오';
    }


감사합니다.